Recordings Are Drifting And/Or Start At The Wrong Time
Welcome to the world of inaccurate timing and sound cards.  If you notice that your recordings are not lining up properly at the start, you'll need to adjust the offset or start time of the recorded sound.  Make sure snap is off and move the sound so that it lines up properly. You'll want to zoom in for the best accuracy.  Switching to an ASIO driver may help.  In addition, purchasing a better sound device may help.

However, if you're noticing that your recordings are slowly drifting over time, the problem is due to an inaccurate clock on your sound card or sound device.  Each device is made with more or less accurate clocks and not all devices have the same time as an atomic clock, for example.

If you have a Soundblaster LIVE, try recording in 48 kHz mode, by switching your Sound Device preferences to use the sample rate of 48,000 Hz.

Drift Work Around
Assuming the start of the sound is lined up properly, go to the end of the sound and visually time stretch it with FlexAudio using the Ctrl key so that it lines up properly.  Make sure to change the pitch shift mode to Do Not Fix Pitch.   Once you've lined up the end of the recording, you should be able to go to the Sound Details Tab to view the time stretch percentage that was needed to get it in sync.  (Example percentages will be around 99.995% or 100.004%)  You can simply apply this drift percentage to all recordings after that.  (Don't forget to change the pitch shift mode to Do Not Fix Pitch)!